1 # Maintainer: Anatol Pomozov
2 # Contributor: Andrew Sun <adsun701 at gmail dot com>
3 # Contributor: Joel Teichroeb <joel at teichroeb dot net>
4 # Contributor: Alim Gokkaya <alimgokkaya at gmail dot com>
9 pkgdesc='The Apache Kafka C/C++ library'
11 url='https://github.com/edenhill/librdkafka'
23 makedepends=(python rapidjson)
24 source=(librdkafka-$pkgver.tar.gz::https://github.com/edenhill/librdkafka/archive/v$pkgver.tar.gz)
25 sha256sums=('7be1fc37ab10ebdc037d5c5a9b35b48931edafffae054b488faaff99e60e0108')
29 ./configure --prefix=/usr
34 make -k check -C $pkgname-$pkgver
38 make DESTDIR="$pkgdir" install -C $pkgname-$pkgver
39 install -vDm 644 $pkgname-$pkgver/LICENSE* -t "$pkgdir/usr/share/licenses/$pkgname/"