archrelease: copy trunk to community-any
[arch-community.git] / libsysstat / trunk / PKGBUILD
blob35ff069094f72e4b94d42b8e42a7a2eeea1ad639
1 # Maintainer: Jerome Leclanche <jerome@leclan.ch>
2 # Co-Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
4 pkgname=libsysstat
5 pkgver=0.4.6
6 pkgrel=2
7 pkgdesc="Library to query system statistics (net, resource usage, ...)"
8 arch=("x86_64")
9 url="https://github.com/lxqt/$pkgname"
10 license=("LGPL2.1")
11 depends=("qt5-base")
12 makedepends=("lxqt-build-tools")
13 source=(
14         "https://github.com/lxqt/libsysstat/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
15         "https://github.com/lxqt/libsysstat/releases/download/$pkgver/$pkgname-$pkgver.tar.xz.asc"
17 sha512sums=('dd0e6f67509658691082b043e06589c6a89eea016a0e68cdb7d377f25a0bc63aa476b5eb90f230593daab462a9e22f6f636c0723110fb36faeea7c0aa6d0b85b'
18             'SKIP')
19 validpgpkeys=(
20         "169704C6FB490C6892C7F23C37E0AF1FDA48F373"  # Jerome Leclanche <jerome@leclan.ch>
21         "7C733BA5F585AAD669E4D23A42C9C8D3AF5EA5E3"  # Alf Gaida <agaida@siduction.org>
22         "19DFDF3A579BD509DBB572D8BE793007AD22DF7E"  # Pedram Pourang <tsujan2000@gmail.com>
25 build() {
26         mkdir -p build
27         cd build
28         cmake "$srcdir/$pkgname-$pkgver" \
29                 -DCMAKE_INSTALL_PREFIX=/usr
30         make
33 package() {
34         cd build
35         make DESTDIR="$pkgdir" install