archrelease: copy trunk to community-any
[arch-community.git] / lua-language-server / trunk / PKGBUILD
blobecc8cc6fab6bd7c31df839dd2349f9afdb9c975f
1 # Maintainer: Daniel M. Capella <polyzen@archlinux.org>
2 # Maintainer: Caleb Maclennan <caleb@alerque.com>
3 # Contributor: KokaKiwi <kokakiwi+aur@kokakiwi.net>
4 # Contributor: Mohammad AlSaleh <CE.Mohammad.AlSaleh at gmail dot com>
6 pkgname=lua-language-server
7 pkgver=3.6.19
8 pkgrel=1
9 license=('MIT')
10 pkgdesc='Lua Language Server coded by Lua'
11 url=https://github.com/LuaLS/lua-language-server
12 arch=('x86_64')
13 depends=('bash' 'gcc-libs')
14 makedepends=('git' 'ninja')
15 source=("git+$url.git#tag=$pkgver"
16         'git+https://github.com/actboy168/bee.lua.git'
17         'git+https://github.com/love2d-community/love-api.git'
18         'git+https://github.com/bjornbytes/lovr-docs.git'
19         'git+https://github.com/sqmedeiros/lpeglabel.git'
20         'git+https://github.com/actboy168/luamake.git'
21         'git+https://github.com/electron/rcedit.git'
22         'wrapper')
23 b2sums=('SKIP'
24         'SKIP'
25         'SKIP'
26         'SKIP'
27         'SKIP'
28         'SKIP'
29         'SKIP'
30         '2ec98b16514c8e416af10625fd582d081448dbe7889d3d9e1fee0540c79f26220bd4b91991c0479852c0102f4c35b63059fe176a59fffbbca8e01274171c7de2')
32 prepare() {
33   cd $pkgname
34   git submodule init
35   for i in ../{bee.lua,love-api,lpeglabel,luamake,rcedit}; do
36     git config submodule.3rd/"${i##../}".url "$i"
37   done
38   git config submodule.3rd/lovr-api.url ../lovr-docs
39   git -c protocol.file.allow=always submodule update
40   cd 3rd/luamake
41   git submodule init
42   git config submodule.3rd/bee.lua.url ../../../bee.lua
43   git -c protocol.file.allow=always submodule update
46 build() {
47   cd $pkgname
48   ninja -C 3rd/luamake -f compile/ninja/linux.ninja
49   ./3rd/luamake/luamake rebuild
52 package() {
53   install -D wrapper "$pkgdir"/usr/bin/$pkgname
54   cd $pkgname
55   install -Dt "$pkgdir"/usr/lib/$pkgname/bin bin/$pkgname
56   install -m644 -t "$pkgdir"/usr/lib/$pkgname/bin bin/main.lua
57   install -m644 -t "$pkgdir"/usr/lib/$pkgname {debugger,main}.lua
58   cp -r locale meta script "$pkgdir"/usr/lib/$pkgname
59   install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
62 # vim:set ts=2 sw=2 et: