archrelease: copy trunk to community-any
[arch-community.git] / perl-extutils-cppguess / trunk / PKGBUILD
blob97f6358e51c4dbae05d951ce7342a6304621e142
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=perl-extutils-cppguess
4 pkgver=0.26
5 pkgrel=1
6 pkgdesc="Guess C++ compiler and flags"
7 arch=('any')
8 license=('PerlArtistic')
9 url="https://metacpan.org/release/ExtUtils-CppGuess"
10 depends=('perl-capture-tiny')
11 makedepends=('perl-module-build')
12 options=('!emptydirs')
13 source=("https://cpan.metacpan.org/authors/id/E/ET/ETJ/ExtUtils-CppGuess-$pkgver.tar.gz")
14 sha512sums=('35e8e11f7df5d4a2a306cbe1df7a879291cb041677c740d95fc228e8ee812a127be4c70bc2ae6b25d3e73de69e1796539dacf3bb0b1a3311de3dea588335a225')
16 build() {
17   cd ExtUtils-CppGuess-$pkgver
18   perl Makefile.PL INSTALLDIRS=vendor
19   make
22 check() {
23   cd ExtUtils-CppGuess-$pkgver
24   make test
27 package() {
28   cd ExtUtils-CppGuess-$pkgver
29   make DESTDIR="$pkgdir" install