archrelease: copy trunk to community-any
[arch-community.git] / perl-file-copy-recursive-reduced / trunk / PKGBUILD
blob787d5b389d2d6517a6c30bfef953b4600465ddd4
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=perl-file-copy-recursive-reduced
4 pkgver=0.006
5 pkgrel=6
6 pkgdesc="Recursive copying of files and directories within Perl 5 toolchain"
7 arch=('any')
8 license=('PerlArtistic' 'GPL')
9 options=('!emptydirs')
10 depends=('perl')
11 makedepends=('perl-capture-tiny' 'perl-path-tiny')
12 url='https://search.cpan.org/dist/File-Copy-Recursive-Reduced'
13 source=("https://search.cpan.org/CPAN/authors/id/J/JK/JKEENAN/File-Copy-Recursive-Reduced-$pkgver.tar.gz")
14 sha512sums=('7cf888b8c004d9430c87c1cceba25e997cb12974a79c3f4d803b11779abef81f5b686caac4c46a70caadb2eee12a71cb1fb87abfc7d5fec43dc37bbd2ef07694')
16 build() {
17   cd "$srcdir/File-Copy-Recursive-Reduced-$pkgver"
18   perl Makefile.PL INSTALLDIRS=vendor
19   make
22 check() {
23   cd "$srcdir/File-Copy-Recursive-Reduced-$pkgver"
24   make test
27 package() {
28   cd "$srcdir/File-Copy-Recursive-Reduced-$pkgver"
29   make DESTDIR="$pkgdir" install
32 # vim:set ts=2 sw=2 et: