archrelease: copy trunk to community-any
[arch-community.git] / perl-font-afm / repos / community-any / PKGBUILD
blobebd4770c7d28580ca0595ecf2b7c999341d8c6fd
1 # Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
2 # Maintainer: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
3 # Contributor: François Charette <firmicus ατ gmx δοτ net>
5 pkgname=perl-font-afm
6 pkgver=1.20
7 pkgrel=11
8 pkgdesc="Parse Adobe Font Metric files"
9 arch=('any')
10 url="https://search.cpan.org/dist/Font-AFM"
11 license=('GPL' 'PerlArtistic')
12 depends=('perl>=5.5.0')
13 options=('!emptydirs')
14 source=("https://search.cpan.org/CPAN/authors/id/G/GA/GAAS/Font-AFM-$pkgver.tar.gz")
15 md5sums=('b14ecf4dc4edbd63940aa354eb13c499')
17 build() {
18   cd "$srcdir/Font-AFM-$pkgver"
19   export \
20         PERL_MM_USE_DEFAULT=1 \
21         PERL_AUTOINSTALL=--skipdeps \
22         PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='"$pkgdir"'" \
23         PERL_MB_OPT="--installdirs vendor --destdir '"$pkgdir"'" \
24         MODULEBUILDRC=/dev/null
25   perl Makefile.PL
26   make
29 check() {
30   cd "$srcdir/Font-AFM-$pkgver"
31   make test
34 package() {
35   cd "$srcdir/Font-AFM-$pkgver"
36   make install
37   find "$pkgdir" -name .packlist -o -name perllocal.pod -delete