archrelease: copy trunk to community-any
[arch-community.git] / perl-www-mechanize / trunk / PKGBUILD
blob5d69051e153c1458c7ed63e1f436638ffb2e2626
1 # Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
2 # Contributor: Francois Charette <firmicus@gmx.net>
4 pkgname=perl-www-mechanize
5 pkgver=2.17
6 pkgrel=1
7 pkgdesc="Automates web page form & link interaction"
8 arch=(any)
9 url="https://search.cpan.org/dist/WWW-Mechanize"
10 license=('GPL' 'PerlArtistic')
11 depends=('perl-libwww' 'perl-html-parser' 'perl-uri' 'perl-http-response-encoding'
12          'perl-http-server-simple' 'perl-test-warn' 'perl-html-form')
13 options=('!emptydirs')
14 source=("https://cpan.metacpan.org/authors/id/S/SI/SIMBABQUE/WWW-Mechanize-$pkgver.tar.gz")
15 sha256sums=('9c02003e84621dea12c980c4101e79e4f8cae4e382cd3da239faa8bd198f063a')
17 build() {
18   cd  "$srcdir"/WWW-Mechanize-$pkgver
19   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
20   make
23 package() {
24   cd  "$srcdir"/WWW-Mechanize-$pkgver
25   make install DESTDIR="$pkgdir"
26   find "$pkgdir" -name '.packlist' -delete
27   find "$pkgdir" -name '*.pod' -delete