archrelease: copy trunk to community-any
[arch-community.git] / perl-xml-libxslt / trunk / PKGBUILD
blob62a9a40cceed78ed105c9dd9de759b278a11f429
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Jonathan Steel <jsteel@aur.archlinux.org>
3 # Contributor: Justin "juster" Davis <jrcd83@gmail.com>
4 # Contributor: François Charette <firmicus ατ gmx δοτ net>
6 pkgname=perl-xml-libxslt
7 pkgver=2.002001
8 pkgrel=1
9 pkgdesc="Interface to the gnome libxslt library"
10 arch=('x86_64')
11 url="https://search.cpan.org/dist/XML-LibXSLT"
12 license=('GPL')
13 depends=('perl-xml-libxml' 'libxslt')
14 checkdepends=('perl-test-pod')
15 options=('!emptydirs')
16 source=(https://www.cpan.org/authors/id/S/SH/SHLOMIF/XML-LibXSLT-$pkgver.tar.gz)
17 sha512sums=('1fbe09fbab1e9729a369090c5aa468436b84280200b55be22a3447b624849acf4ccc11898fdcf608c333eb6fbcf19c37adf7a3b7943f71cd6c9aea0800edfa04')
19 build() {
20   cd XML-LibXSLT-$pkgver
21   perl Makefile.PL INSTALLDIRS=vendor
22   make
25 check() {
26   cd XML-LibXSLT-$pkgver
27   make test
30 package() {
31   cd XML-LibXSLT-$pkgver
32   make DESTDIR="$pkgdir" install