1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Padraic Fanning <fanninpm AT miamioh DOT edu>
4 pkgname=python-darkdetect
7 pkgdesc='Detect OS Dark Mode from Python'
9 url='https://github.com/albertosottile/darkdetect'
19 _commit='64ce54e20be54cc41f85c8c208d35a4137b958d3'
20 source=("$pkgname::git+$url.git#commit=$_commit")
26 git describe --tags | sed 's/^v//'
32 python -m build --wheel --no-isolation
38 python -m installer --destdir="$pkgdir" dist/*.whl
40 install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE