archrelease: copy trunk to community-any
[arch-community.git] / python-darkdetect / trunk / PKGBUILD
blobd0f024b0ab4dfaa380e1246026cfc04edf8b7f52
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Padraic Fanning <fanninpm AT miamioh DOT edu>
4 pkgname=python-darkdetect
5 pkgver=0.8.0
6 pkgrel=2
7 pkgdesc='Detect OS Dark Mode from Python'
8 arch=('any')
9 url='https://github.com/albertosottile/darkdetect'
10 license=('BSD')
11 depends=('python')
12 makedepends=(
13   'git'
14   'python-build'
15   'python-installer'
16   'python-wheel'
17   'python-setuptools'
19 _commit='64ce54e20be54cc41f85c8c208d35a4137b958d3'
20 source=("$pkgname::git+$url.git#commit=$_commit")
21 b2sums=('SKIP')
23 pkgver() {
24   cd "$pkgname"
26   git describe --tags | sed 's/^v//'
29 build() {
30   cd "$pkgname"
32   python -m build --wheel --no-isolation
35 package() {
36   cd "$pkgname"
38   python -m installer --destdir="$pkgdir" dist/*.whl
40   install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE