archrelease: copy trunk to community-any
[arch-community.git] / python-designateclient / trunk / PKGBUILD
blobc682311877b8e9adea4a60ddb5532dd7555dbe8c
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
4 pkgname=python-designateclient
5 pkgver=5.2.0
6 _commit=bc39d23ff5ff45e7669cb4be9d2c28b9242cf9d9
7 pkgrel=2
8 pkgdesc="OpenStack DNS-as-a-Service - Client"
9 arch=('any')
10 url="https://docs.openstack.org/python-designateclient/latest/"
11 license=('Apache')
12 depends=('python-cliff' 'python-jsonschema' 'python-osc-lib' 'python-oslo-serialization'
13          'python-oslo-utils' 'python-pbr' 'python-keystoneauth1' 'python-requests' 'python-six'
14          'python-stevedore' 'python-debtcollector')
15 makedepends=('git')
16 checkdepends=('python-oslotest' 'python-requests-mock')
17 source=("git+https://github.com/openstack/python-designateclient.git#commit=$_commit")
18 sha512sums=('SKIP')
20 build() {
21   cd python-designateclient
22   python setup.py build
25 check() {
26   cd python-designateclient
27   stestr run
30 package() {
31   cd python-designateclient
32   python setup.py install --root="$pkgdir" --optimize=1