archrelease: copy trunk to community-any
[arch-community.git] / python-eventlet / trunk / PKGBUILD
blobcb587d5e3a76f27e72534c5f863ecc083d5b23ae
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
3 pkgname=python-eventlet
4 _pyname=eventlet
5 pkgver=0.33.3
6 pkgrel=2
7 pkgdesc='Highly concurrent networking library'
8 url='https://eventlet.net'
9 arch=('any')
10 license=('MIT')
11 depends=('python' 'python-greenlet' 'python-six' 'python-dnspython')
12 makedepends=('python-setuptools' 'python-sphinx')
13 checkdepends=('python-psycopg2' 'python-nose' 'python-pyopenssl' 'python-httplib2' 'python-mock' 'python-pyzmq')
14 optdepends=(
15   'python-psycopg2: non-blocking PostgreSQL support'
16   'python-pyopenssl: non-blocking SSL support'
17   'python-httplib2: non-blocking HTTP support'
18   'python-pyzmq: non-blocking ZeroMQ support'
19   'python-dnspython: non-blocking DNS support'
21 options=('!makeflags')
22 source=(https://github.com/eventlet/eventlet/archive/v${pkgver}/${_pyname}-${pkgver}.tar.gz
23         python310.patch)
24 sha512sums=('b2e1818c7b6134be4020d2b4315bbb3db795960df76da08a490e0d952549eafb477800c884e7a99493146c1ac082aed5fb87c7e2882ee468ea42b5cc26b8517f'
25             '07739075628ff9d140064e04189332b479f184e4647753f987b0818fa55aaca907d4880afb5cf31f980426f315e1014027dcd848551149000a12145f982cd883')
26 b2sums=('19bcd7a5adc2ef24f2637bfd9b19e68a9a268ebb7791cc9c419d9da88e5860c4cbbf6ecbaa0f3c300246584082622e6dab7ab75374f7d54f3c4a65661e22dbfd'
27         '783445f708c12586e026f7feac982a7b6c21f86468609c375568b51ad6055977df3d0bc740f3127b9f8bc95c1c50e81aae02ca0e0be674ed4627910d39b1ef47')
29 prepare() {
30   cd ${_pyname}-${pkgver}
31   # https://github.com/eventlet/eventlet/issues/730
32   # https://github.com/eventlet/eventlet/issues/739
33   patch -Np1 -i ../python310.patch
34   sed -r 's|(check_idle_cpu_usage\(.*,) .*\)|\1 0.8\)|g' -i tests/*_test.py
37 build() {
38   cd ${_pyname}-${pkgver}
39   python setup.py build
40   make -C doc text
43 check() {
44   cd ${_pyname}-${pkgver}
45   nosetests -sv tests -e test_018b_http_10_keepalive_framing # fails on build.a.o
48 package() {
49   cd ${_pyname}-${pkgver}
50   python setup.py install --prefix=/usr --root="${pkgdir}" -O1
51   install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
52   install -d "${pkgdir}/usr/share/doc/${pkgname}"
53   cp -r doc/_build/text "${pkgdir}/usr/share/doc/${pkgname}"
54   cp -r examples "${pkgdir}/usr/share/doc/${pkgname}"
57 # vim: ts=2 sw=2 et: