archrelease: copy trunk to community-any
[arch-community.git] / python-execnet / trunk / PKGBUILD
blobaca3db43fce6d010f1d7cca21305a82457cc7979
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-execnet
4 pkgver=1.9.0
5 pkgrel=6
6 pkgdesc="Rapid multi-Python deployment"
7 arch=('any')
8 license=('MIT')
9 url="https://codespeak.net/execnet"
10 depends=('python')
11 makedepends=(
12   'python-build'
13   'python-installer'
14   'python-setuptools-scm'
15   'python-wheel'
17 checkdepends=(
18   'openssh'
19   'procps-ng'
20   'python-py'
21   'python-pytest'
22   'python-pytest-timeout'
24 source=("https://pypi.io/packages/source/e/execnet/execnet-$pkgver.tar.gz")
25 sha512sums=('d425e7b6f3708efecb5dfa2c36a837cb55f2c32cf2ec0c1dc11cd1ca6ea614d119d04908b84dd5a3593c87db35e71fee202f843665c853ac3538479f60c83d60')
27 build() {
28   cd execnet-$pkgver
29   python -m build --wheel --no-isolation
32 check() {
33   local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
35   cd execnet-$pkgver
36   # install to temporary location, as importlib is used
37   python -m installer --destdir=test_dir dist/*.whl
38   export PYTHONPATH="test_dir/$site_packages:$PYTHONPATH"
39   pytest -vv testing
42 package() {
43   cd execnet-$pkgver
44   python -m installer --destdir="$pkgdir" dist/*.whl
45   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/