1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Daniel M. Capella <polyzen@archlinux.org>
3 # Contributor: Pieter Goetschalckx <3.14.e.ter <at> gmail <dot> com>
5 pkgname=python-flake8-docstrings
8 pkgdesc='Plugin to flake8 to include checks provided by pydocstyle'
10 url='https://github.com/pycqa/flake8-docstrings'
12 depends=('python' 'flake8' 'python-pydocstyle')
20 _commit='cd8a6e79f276b8b9d085776e5c2d8fc256f77e30'
21 source=("$pkgname::git+$url#commit=$_commit")
27 git describe --tags | sed 's/^v//'
33 python -m build --wheel --no-isolation
39 python -m installer --destdir="$pkgdir" dist/*.whl
42 local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
43 install -d "$pkgdir/usr/share/licenses/$pkgname"
44 ln -s "$site_packages/flake8_docstrings-$pkgver.dist-info/LICENSE" \
45 "$pkgdir/usr/share/licenses/$pkgname/LICENSE"