archrelease: copy trunk to community-any
[arch-community.git] / python-hatch-jupyter-builder / trunk / PKGBUILD
blob835eb0dae8d4890a9ffe9c80b451bd3e3adc5abf
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 _pipname=hatch_jupyter_builder
4 pkgname=python-hatch-jupyter-builder
5 pkgver=0.8.3
6 pkgrel=2
7 pkgdesc='A hatch plugin to help build Jupyter packages'
8 arch=(any)
9 url='https://jupyter.org/'
10 license=(custom)
11 depends=(python-hatchling)
12 makedepends=(python-build python-installer)
13 checkdepends=(python-pytest python-pytest-mock)
14 source=(https://github.com/jupyterlab/hatch-jupyter-builder/releases/download/v$pkgver/${_pipname//-/_}-$pkgver.tar.gz)
15 sha256sums=('0dbd14a8aef6636764f88a8fd1fcc9a91921e5c50356e6aab251782f264ae960')
17 build() {
18   cd $_pipname-$pkgver
19   python -m build --wheel --no-isolation
22 check() {
23   cd $_pipname-$pkgver
24   pytest -v
27 package() {
28   cd $_pipname-$pkgver
29   python -m installer --destdir="$pkgdir" dist/*.whl
31   install -Dm644 LICENSE.txt -t "$pkgdir"/usr/share/licenses/$pkgname