1 # Maintainer: Bruno Pagani <archange@archlinux.org>
4 pkgname=python-${_pkg,,}
7 pkgdesc="Heap with decrease-key and increase-key operations"
9 url="https://github.com/DanielStutzbach/heapdict"
11 makedepends=(python-setuptools)
13 checkdepends=(python-tests)
14 source=(https://files.pythonhosted.org/packages/source/${_pkg::1}/${_pkg}/${_pkg}-${pkgver}.tar.gz)
15 #source=(${url}/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
16 sha256sums=('8495f57b3e03d8e46d5f1b2cc62ca881aca392fd5cc048dc0aa2e1a6d23ecdb6')
30 python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
31 install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}/