archrelease: copy trunk to community-any
[arch-community.git] / python-phonenumbers / repos / community-any / PKGBUILD
blob3d27e37e12bf42e9f6938a76b987d736859c0fb9
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-phonenumbers
4 pkgver=8.13.11
5 _commit=653a6b544ea387f33d205a53d475e5eb4cf4466b
6 pkgrel=1
7 pkgdesc="Python version of Google's common library for parsing, formatting, storing and validating international phone numbers"
8 arch=('any')
9 url="https://github.com/daviddrysdale/python-phonenumbers"
10 license=('Apache')
11 depends=('python')
12 makedepends=('git' 'python-setuptools')
13 source=("git+https://github.com/daviddrysdale/python-phonenumbers.git#commit=$_commit")
14 sha512sums=('SKIP')
16 build() {
17   cd python-phonenumbers/python
18   python setup.py build
21 check() {
22   cd python-phonenumbers/python
23   python setup.py test
26 package() {
27   cd python-phonenumbers/python
28   python setup.py install -O1 --root "$pkgdir"