archrelease: copy trunk to community-any
[arch-community.git] / python-pyface / trunk / PKGBUILD
blob669c6aa8d4b565742e24f27a4d9c3ebafa368120
1 # Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
3 # TODO: python-scimath: for unit parser in pyface.wx.spreadsheet
4 # TODO: look for more hidden dependencies
6 pkgname=python-pyface
7 pkgver=8.0.0
8 pkgrel=2
9 pkgdesc="Traits-capable windowing framework"
10 arch=('any')
11 url="https://github.com/enthought/pyface"
12 license=('BSD')
13 depends=('python-traits')
14 makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
15 optdepends=('python-pyqt6: for Qt backend (or pyside2)'
16             'python-pyqt6-webengine: for Qt backend'
17             'pyside6: for Qt backend (or python-pyqt5)'
18             'python-pygments: for syntax coloring in Qt backend'
19             'ipython: for IPython widget'
20             'python-wxpython: for wx backend')
21 options=(!emptydirs)
22 source=("pyface-${pkgver}.tar.gz::https://github.com/enthought/pyface/archive/${pkgver}.tar.gz")
23 sha256sums=('e34f8fb285517e25bfe41a4b8d1d54860d2636bd5fa5b9bff26ab96c1a098895')
25 build() {
26   cd pyface-$pkgver
28   python -m build --wheel --no-isolation
31 package() {
32   cd pyface-$pkgver
34   python -m installer --destdir="$pkgdir" dist/*.whl
36   install -D LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE