archrelease: copy trunk to community-any
[arch-community.git] / python-reactivex / trunk / PKGBUILD
blobcd9952716b21226b0f28667cfad2d02e31900041
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Ilya Elenskiy <elenskiy.ilya@gmail.com>
3 # Contributor: Julien Nicoulaud <julien.nicoulaud@gmail.com>
5 pkgname=python-reactivex
6 pkgver=4.0.4
7 pkgrel=3
8 pkgdesc='Reactive Extensions for Python'
9 arch=(any)
10 url=http://reactivex.io
11 license=(APACHE)
12 depends=(
13   python
14   python-typing_extensions
16 makedepends=(
17   git
18   python-build
19   python-poetry-core
20   python-installer
22 checkdepends=(
23   python-coverage
24   python-nose
25   python-pytest
26   python-pytest-asyncio
28 _tag=7187453c1a829c3f7ceeadae722f2d1d13f6b51e
29 source=(git+https://github.com/ReactiveX/RxPY.git#tag=${_tag})
30 sha256sums=(SKIP)
32 pkgver() {
33   cd RxPY
34   _version=$(git describe --tags | sed 's/^v//')
35   sed "s/0.0.0/${_version}/" -i pyproject.toml
36   echo "__version__ = \"${_version}\"" > reactivex/_version.py
37   echo ${_version}
40 build() {
41   cd RxPY
42   python -m build --wheel --no-isolation
45 check() {
46   cd RxPY
47   python -m pytest
50 package() {
51   python -m installer --destdir="${pkgdir}" RxPY/dist/*.whl
54 # vim: ts=2 sw=2 et: