1 # Maintainer: Bruno Pagani <archange@archlinux.org>
2 # Contributor: Andrzej Giniewicz <gginiu@gmail.com>
3 # Contributor: Oliver Sherouse <oliver DOT sherouse AT gmail DOT com>
8 pkgdesc="Statistical data visualization"
10 url="https://seaborn.pydata.org/"
12 depends=(python-pandas python-matplotlib)
13 makedepends=(python-build python-installer python-flit-core)
14 optdepends=('python-scipy: clustering matrices and some advanced options'
15 'python-statsmodels: advanced regression plots')
16 checkdepends=(python-pytest python-scipy python-statsmodels)
17 source=(https://github.com/mwaskom/seaborn/archive/v$pkgver/$pkgname-$pkgver.tar.gz
18 https://github.com/mwaskom/seaborn/commit/db7ae117.patch)
19 sha256sums=('e11b9b136b583bbbb8b692dcd23ec539ea58c0325f7502cd049392352b815788'
20 '17b591c70d063e6c32805ac06afee557464978a0c24924a90014b659bab187da')
23 patch -d seaborn-$pkgver -p1 < db7ae117.patch # Fix test with matplotlib 3.7
28 python -m build --wheel --no-isolation
33 pytest -vv --color=yes
38 python -m installer --destdir="$pkgdir" dist/*.whl
39 install -Dm644 LICENSE.md -t "$pkgdir"/usr/share/licenses/$pkgname/