1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-zope-location
6 pkgdesc="Special objects that have a structural location"
8 url="https://github.com/zopefoundation/zope.location"
10 depends=('python-setuptools' 'python-zope-interface' 'python-zope-schema' 'python-zope-proxy')
11 checkdepends=('python-zope-testrunner' 'python-zope-copy' 'python-zope-configuration' 'python-zope-component')
12 source=("$pkgname-$pkgver.tar.gz::https://github.com/zopefoundation/zope.location/archive/$pkgver.tar.gz")
13 sha512sums=('af6188ac877f48a2955888fda10e9be9c7d4496184b5b22dff6a62674b4ed31b6bc84bdb7434f75b313679b9e0706cf9025591f8106f8c4f53c3a27ee74c13b6')
16 cd "$srcdir"/zope.location-$pkgver
21 cd "$srcdir"/zope.location-$pkgver
22 PYTHONPATH="$PWD/build/lib:$PYTHONPATH" python -m zope.testrunner --test-path=src || echo "Tests failed"
26 cd zope.location-$pkgver
27 python setup.py install --root="$pkgdir" --optimize=1
30 # vim:set ts=2 sw=2 et: