archrelease: copy trunk to community-any
[arch-community.git] / qt4pas / trunk / PKGBUILD
blobb84b4698485d14eb7187d5048982d448afc5524e
1 # Maintainer: BlackIkeEagle <ike DOT devolder AT gmail DOT com>
2 # Contributor: Fabien Wang <fabien(dot)wang(at)gmail(dot)com>
4 pkgname=qt4pas
5 pkgver=2.5
6 pkgrel=8
7 pkgdesc="Free Pascal Qt4 Binding Library"
8 arch=('x86_64')
9 url="http://users.telenet.be/Jan.Van.hijfte/qtforfpc/fpcqt4.html"
10 license=('LGPL')
11 depends=('qt4' 'xdg-utils')
12 source=(
13     'http://users.telenet.be/Jan.Van.hijfte/qtforfpc/V2.5/qt4pas-V2.5_Qt4.5.3.tar.gz'
14     'qtwebkit.patch'
16 sha256sums=('825423db80da4df5c21816c0392b3394cddfe2f3293dfd08ace84941726affea'
17             'af1721fbf6706931d0b82dd28b3540f56a65e1585b75873c4ac9eaddecf9c921')
19 prepare() {
20         cd "qt4pas-V2.5_Qt4.5.3/"
22     patch -p0 -i "$srcdir/qtwebkit.patch"
25 build() {
26         cd "qt4pas-V2.5_Qt4.5.3/"
28         qmake-qt4 -query
29         qmake-qt4
30         make
33 package() {
34         cd "qt4pas-V2.5_Qt4.5.3/"
36         INSTALL_ROOT="$pkgdir" make install
38         pushd "$pkgdir/usr/lib"
39         for intflink in 'libqt4intf.so' 'libqt4intf.so.5' 'libqt4intf.so.5.2' 'libqt4intf.so.5.2.1' 'libqt4intf.so.5.2.5'; do
40                 ln -s libQt4Pas.so.5.2.5 $intflink
41         done
42         popd