1 # Maintainer: Caleb Maclennan <caleb@alerque.com>
2 # Contributor: Bart Verhagen <bart at verhagenconsultancy dot be>
4 # Upstream has no tags or release versioning, see:
5 # https://github.com/emil-e/rapidcheck/issues/255
6 # Commit here was picked based on what works to build nix.
7 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/development/libraries/rapidcheck/default.nix
8 _commit=b78f89288c7e086d06e2a1e10b605d8375517a8a
13 pkgdesc='QuickCheck clone for C++'
14 arch=(x86_64 aarch64 i686 arm armv6h armv7h)
15 url="https://github.com/emil-e/$pkgname"
20 source=("git+$url.git#commit=$_commit")
31 "$(git rev-list --count HEAD)" \
32 "$(git rev-parse --short=7 HEAD)"
39 -D CMAKE_BUILD_TYPE=Release \
40 -D CMAKE_INSTALL_PREFIX="$pkgdir/usr/" \
41 -D CMAKE_POSITION_INDEPENDENT_CODE=True \
42 -D RC_ENABLE_EXAMPLES=Off \
43 -D RC_ENABLE_TESTS=Off \
44 -D RC_INSTALL_ALL_EXTRAS=On \
53 -D CMAKE_POSITION_INDEPENDENT_CODE=True \
54 -D RC_ENABLE_EXAMPLES=On \
57 build/examples/counter/counter
60 package_rapidcheck() {
62 cmake -P "build/cmake_install.cmake"
63 install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE.md