archrelease: copy trunk to community-any
[arch-community.git] / regexxer / trunk / PKGBUILD
blob6c710f5a0a3d9133fbb72e54076e351f0ccde180
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
3 pkgname=regexxer
4 pkgver=0.10
5 pkgrel=10
6 pkgdesc="Interactive search and replace tool for GNOME"
7 arch=('x86_64')
8 url="http://regexxer.sourceforge.net/"
9 license=('GPL')
10 depends=('gtksourceviewmm')
11 makedepends=('intltool')
12 source=(https://download.gnome.org/sources/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz
13         regexxer.appdata.xml
14         regexxer-glib2.32.patch
15         fix-deprecated.patch)
16 sha256sums=('2a7832541a0306b3d4eb63a1cf8978d7bbfc7927e9304473fe801d71fd99736c'
17             'dafeaeacace596bc4313262090e15713b99d9f95420e535155735582d8dc206a'
18             '1addebc552e4374f3f9ee778fb734c08c1ed3a4b2b5e70905f7c9287c9b34882'
19             'e2548ccf46a4eeabcda4221f6feec6d961eaef7ae8f7a8998b6374c61a7ae77a')
21 prepare() {
22   cd $pkgname-$pkgver
24   # Port to glib 2.32
25   patch -Np1 -i ../regexxer-glib2.32.patch
27   # Fix deprecations
28   patch -Np1 -i ../fix-deprecated.patch
30   # Don't try to compile GSettings schemas when packaging
31   sed -i '/GLIB_COMPILE_SCHEMAS/ d' Makefile.in
34 build() {
35   cd $pkgname-$pkgver
36   CXXFLAGS+=' -std=c++11'
37   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
38               --disable-schemas-compile
39   make
42 package() {
43   cd $pkgname-$pkgver
44   make DESTDIR="$pkgdir" install
45   install -Dm644 ../regexxer.appdata.xml "$pkgdir/usr/share/metainfo/regexxer.appdata.xml"