archrelease: copy trunk to community-any
[arch-community.git] / rtmidi / trunk / PKGBUILD
blob6d5fb02c976102bdc029f6729c24bf7b7c4839c2
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Llewelyn Trahaearn <WoefulDerelict at GMail dot com>
3 # Contributor: rtfreedman  <rob dot til dot freedman at gmail dot com>
4 # Contributor: speps <speps at aur dot archlinux dot org> 
6 pkgbase=rtmidi
7 pkgname=(
8   rtmidi
9   rtmidi-docs
11 pkgver=5.0.0
12 pkgrel=2
13 pkgdesc="A set of C++ classes that provides a common API for realtime MIDI input/output."
14 arch=(x86_64)
15 url="https://www.music.mcgill.ca/~gary/rtmidi/"
16 license=(custom:RtMidi)
17 makedepends=(
18   alsa-lib
19   doxygen
20   gcc-libs
21   glibc
22   jack
24 source=(https://github.com/thestk/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz)
25 sha512sums=('f154905af9a8a85bf543f88035e8744970afe703ea3b4b2f21d85e246cf841fc86b47fd402a81bef27d4233c0d8ccf51943dc2fa42dfdd5447e1f5c3d6634297')
26 b2sums=('74a4dac921abf1d6bc102bfd6e4edd3b9dd7fead045ded15c8793168348e330e896af5d87ae4dfa8128baf4de99660a89e191e29b2135d2a446e3fcddb37f53f')
28 prepare() {
29   cd $pkgname-$pkgver
30   autoreconf -fiv
33 build() {
34   local configure_options=(
35     --prefix=/usr
36     --with-alsa
37     --with-jack
38   )
40   cd $pkgname-$pkgver
41   ./configure "${configure_options[@]}"
42   # prevent overlinking due to libtool
43   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
44   make
47 package_rtmidi() {
48   depends=(
49     alsa-lib
50     gcc-libs
51     glibc
52     jack
53   )
54   optdepends=('rtmidi-docs: for documentation')
55   provides=(librtmidi.so)
57   make DESTDIR="$pkgdir" install -C $pkgbase-$pkgver
58   install -vDm 644 $pkgbase-$pkgver/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
61 package_rtmidi-docs() {
62   pkgdesc+=" - documentation"
64   install -vDm 644 $pkgbase-$pkgver/{README.md,doc/release.txt} -t "$pkgdir/usr/share/doc/$pkgbase/"
65   install -vDm 644 $pkgbase-$pkgver/doc/html/* -t "$pkgdir/usr/share/doc/$pkgbase/html"
66   install -vDm 644 $pkgbase-$pkgver/doc/images/* -t "$pkgdir/usr/share/doc/$pkgbase/images"
67   install -vDm 644 $pkgbase-$pkgver/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"