archrelease: copy trunk to community-any
[arch-community.git] / sshuttle / trunk / PKGBUILD
blobd711267337b7397cc144fc5dc41e380004fc9901
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: alphazo <alphazo@gmail.com>
4 pkgname=sshuttle
5 pkgver=1.1.1
6 pkgrel=2
7 pkgdesc='Transparent proxy server that forwards all TCP packets over ssh'
8 arch=('any')
9 url="https://github.com/sshuttle/sshuttle"
10 license=('GPL2')
11 depends=('iptables' 'openssh' 'net-tools')
12 makedepends=('python-sphinx' 'python-setuptools')
13 checkdepends=('python-pytest')
14 backup=('etc/sshuttle/tunnel.conf' 'etc/sshuttle/prefixes.conf')
15 source=("https://github.com/sshuttle/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
16         'sshuttle.service' 'prefixes.conf' 'tunnel.conf')
17 sha512sums=('4f670bee34653e47cf7a0c8550b2ac734230ccf0d4fb6191ae3a0c6404847c788c3cdf033bc1571f49472729029077aa6d6970f4bce78fa4980f1f29ccbd2f7a'
18             'c22504798f6220cd6b0946d6975375437c52753a241cd2a6a03d3aeb005ed1d78e6356dde23716e2514ccf6d7f1c6aace43956dbeede1bf028753b9bdcdd8b7d'
19             'cc5a5dee7991c7641fa8a4fb356e1977aa9d1cbfed63cb5ebf8732c4de76be841f66d9267472e70578b176f528d8cfb4f75e634d5d915f4c8bcdc0b801db8a13'
20             'acd3d0024d4604cc6a96609286c3f27bce2f0b70a068f58a2110dacc235b22ba7cd83c8989f46d0a9391eda7d272040bb3b1b2c547ae3fa0c9f61bef0a187dda')
22 prepare() {
23   cd $pkgname-$pkgver
24   sed -i '/--cov/d' setup.cfg
27 build() {
28   cd $pkgname-$pkgver
29   python setup.py build
31   cd docs
32   make man
35 check() {
36   cd $pkgname-$pkgver
37   PYTHONPATH="$PWD/build/lib" pytest
40 package() {
41   cd $pkgname-$pkgver
42   python setup.py install --root="$pkgdir" -O1
44   install -Dm644 docs/_build/man/sshuttle.1 "$pkgdir"/usr/share/man/man1/sshuttle.1
46   install -d "$pkgdir"/etc/sshuttle
47   install -m644 "$srcdir"/{tunnel.conf,prefixes.conf} "$pkgdir"/etc/sshuttle
48   install -Dm644 "$srcdir"/sshuttle.service "$pkgdir"/usr/lib/systemd/system/sshuttle.service