1 # Maintainer: Forest Crossman <cyrozap at gmail dot com>
6 pkgdesc="Simple Theorem Prover"
8 url="https://stp.github.io/"
10 depends=('boost-libs' 'cryptominisat5' 'minisat')
11 makedepends=('boost' 'cmake' 'help2man' 'ninja' 'python')
12 source=("https://github.com/$pkgname/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz"
14 sha256sums=('ea6115c0fc11312c797a4b7c4db8734afcfce4908d078f386616189e01b4fffa'
15 '4c09301c5a36cd89845a7177e1215008f8bbb23fa6f3c6cc941006825e28c327')
18 # Correct the destination for man documentation.
19 patch -d $pkgname-$pkgver < mandir.patch
23 sed -i '/RPATH/d' $pkgname-$pkgver/{,tools/stp/,tools/stp_simple/}CMakeLists.txt
30 -DCMAKE_INSTALL_PREFIX=/usr \
31 -DCMAKE_INSTALL_LIBDIR=lib \
32 -DENABLE_PYTHON_INTERFACE=ON \
39 install -Dm644 LICENSE LICENSE_COMPONENTS -t "$pkgdir"/usr/share/licenses/$pkgname/
42 DESTDIR="$pkgdir" ninja install
45 # vim:set ts=2 sw=2 et: