archrelease: copy trunk to community-any
[arch-community.git] / stp / trunk / PKGBUILD
blob0fcb46c22fc13fa9d1b0f9f2ff8592ffdb58b3f4
1 # Maintainer: Forest Crossman <cyrozap at gmail dot com>
3 pkgname=stp
4 pkgver=2.3.3
5 pkgrel=9
6 pkgdesc="Simple Theorem Prover"
7 arch=('i686' 'x86_64')
8 url="https://stp.github.io/"
9 license=('MIT')
10 depends=('boost-libs' 'cryptominisat5' 'minisat')
11 makedepends=('boost' 'cmake' 'help2man' 'ninja' 'python')
12 source=("https://github.com/$pkgname/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz"
13         'mandir.patch')
14 sha256sums=('ea6115c0fc11312c797a4b7c4db8734afcfce4908d078f386616189e01b4fffa'
15             '4c09301c5a36cd89845a7177e1215008f8bbb23fa6f3c6cc941006825e28c327')
17 prepare() {
18   # Correct the destination for man documentation.
19   patch -d $pkgname-$pkgver < mandir.patch
20   mkdir -p build
22   # Remove RPATH
23   sed -i '/RPATH/d' $pkgname-$pkgver/{,tools/stp/,tools/stp_simple/}CMakeLists.txt
26 build() {
27   cd build
28   cmake \
29     -GNinja \
30     -DCMAKE_INSTALL_PREFIX=/usr \
31     -DCMAKE_INSTALL_LIBDIR=lib \
32     -DENABLE_PYTHON_INTERFACE=ON \
33     ../$pkgname-$pkgver
34   ninja
37 package() {
38   cd $pkgname-$pkgver
39   install -Dm644 LICENSE LICENSE_COMPONENTS -t "$pkgdir"/usr/share/licenses/$pkgname/
41   cd ../build
42   DESTDIR="$pkgdir" ninja install
45 # vim:set ts=2 sw=2 et: