1 # Maintainer: Sven-Hendrik Haase <svenstaro@archlinux.org>
2 # Contributor: Sýlvan Heuser <sylvan.heuser@gmx.net>
6 pkgdesc='Secure Terminal Sharing, an alternative to tmate'
8 url="https://github.com/owenthereal/upterm"
12 source=("${pkgname}-${pkgver}.tar.gz::https://github.com/owenthereal/upterm/archive/v${pkgver}.tar.gz")
13 sha256sums=('05409ae3a124d611221f64e87016d67cfd2d3a125fcfec95abb9a123acd9d1a2')
16 cd "${pkgname}-${pkgver}"
22 cd "${pkgname}-${pkgver}"
23 export CGO_CPPFLAGS="${CPPFLAGS}"
24 export CGO_CFLAGS="${CFLAGS}"
25 export CGO_CXXFLAGS="${CXXFLAGS}"
26 export CGO_LDFLAGS="${LDFLAGS}"
27 export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
28 go build -o build ./cmd/...
33 cd "${pkgname}-${pkgver}"
38 cd "${pkgname}-${pkgver}"
39 install -Dm755 "build/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
40 install -Dm755 "build/${pkgname}d" "${pkgdir}/usr/bin/${pkgname}d"
41 install -dm755 "${pkgdir}/usr/share/man"
42 cp -av etc/man/* "${pkgdir}/usr/share/man/"
43 install -Dm644 "etc/completion/upterm.bash_completion.sh" "${pkgdir}/usr/share/bash-completion/completions/upterm"
44 install -Dm644 "etc/completion/upterm.zsh_completion" "${pkgdir}/usr/share/zsh/site-functions/_upterm"
45 install -Dm644 systemd/uptermd.service "${pkgdir}/usr/lib/systemd/system/uptermd.service"
48 # vim:set ts=2 sw=2 et: