archrelease: copy trunk to community-any
[arch-community.git] / xsel / trunk / PKGBUILD
blobeeac717bf668ccea3e3891bbe10a5e82b9790c55
1 # Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
2 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
4 pkgname=xsel
5 pkgver=1.2.1
6 _commit=062e6d373537c60829fa9b5dcddbcd942986b3c3
7 pkgrel=1
8 pkgdesc="Command-line program for getting and setting the contents of the X selection"
9 arch=(x86_64)
10 url="https://vergenet.net/~conrad/software/xsel/"
11 license=("custom")
12 depends=('libx11')
13 makedepends=('libxt' 'git')
14 #source=(https://www.vergenet.net/~conrad/software/xsel/download/$pkgname-$pkgver.tar.gz)
15 source=("git+https://github.com/kfish/xsel.git#tag=${pkgver}")
16 sha512sums=('SKIP')
18 build() {
19   cd $pkgname
20   touch README
21   [ -x configure ] && ./configure --prefix=/usr || ./autogen.sh --prefix=/usr
22   make
25 package() {
26   cd $pkgname
27   make DESTDIR="$pkgdir" install
28   mkdir -p "$pkgdir"/usr/share/licenses/xsel/
29   install -D -m0644 COPYING "$pkgdir"/usr/share/licenses/xsel/COPYING