archrelease: copy trunk to community-any
[arch-community.git] / zsh-completions / trunk / PKGBUILD
blob4ff44d10573ef13780b1d00ba0579a562377af26
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Evgeniy Alekseev <arcanis at archlinux dot org>
3 # Contributor: Julien Nicoulaud <julien.nicoulaud at gmail dot com>
5 pkgname=zsh-completions
6 pkgver=0.34.0
7 pkgrel=4
8 pkgdesc="Additional completion definitions for Zsh"
9 arch=(any)
10 url="https://github.com/zsh-users/zsh-completions"
11 license=(BSD)
12 depends=(zsh)
13 source=($pkgname-$pkgver.tar.gz::https://github.com/zsh-users/$pkgname/archive/refs/tags/$pkgver.tar.gz)
14 sha512sums=('643e967a77ab708c6316a9b43edd8b411f133aa4abe10bf69d3f5e545b2128423ad80d3509e7f9077b30cb8a83f60fe8d4355ed0a697dadffe1e1aaac6597c04')
15 b2sums=('75afed3059e889f92843099ad3eddae1f939a7d9a46d87a8048c5742b44699c2da13a9c2ea00ca2ea02898472199f064c420aac8943338e3b22189a7cc0d23b4')
16 changelog=ChangeLog
18 package() {
19   local completion
20   local provided_completions=(
21     _tmuxp
22     _trash
23     _trash-empty
24     _trash-list
25     _trash-put
26     _trash-restore
27     _vagrant
28   )
30   cd $pkgname-$pkgver
31   install -vDm 644 src/* -t "$pkgdir/usr/share/zsh/site-functions/"
32   install -vDm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
33   install -vDm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
35   # remove completions which are provided by other packages
36   for completion in "${provided_completions[@]}"; do
37     rm -v "$pkgdir/usr/share/zsh/site-functions/$completion"
38   done
41 # vim:set ts=2 sw=2 et: