archrelease: copy trunk to extra-x86_64
[arch-packages.git] / at-spi2-core / repos / extra-x86_64 / PKGBUILD
blob5a35eb20302cab6344131b3444cd493c86193e4b
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgbase=at-spi2-core
5 pkgname=(
6   at-spi2-core
7   at-spi2-core-docs
9 pkgver=2.48.1
10 pkgrel=2
11 pkgdesc="Protocol definitions and daemon for D-Bus at-spi"
12 url="https://gitlab.gnome.org/GNOME/at-spi2-core"
13 arch=(x86_64)
14 license=(GPL2)
15 depends=(
16   dbus
17   glib2
18   gsettings-desktop-schemas
19   libx11
20   libxml2
21   libxtst
22   systemd
24 makedepends=(
25   dbus-broker
26   gi-docgen
27   git
28   gobject-introspection
29   meson
30   python-sphinx
32 checkdepends=(
33   at-spi2-core
35 _commit=6ee2b837cc378a0438c5b615c014026cf15e9954  # tags/AT_SPI2_CORE_2_48_1^0
36 source=("git+https://gitlab.gnome.org/GNOME/at-spi2-core.git#commit=$_commit")
37 b2sums=('SKIP')
39 pkgver() {
40   cd at-spi2-core
41   git describe --tags | sed 's/^AT_SPI2_CORE_//;s/_/./g;s/-/+/g'
44 prepare() {
45   cd at-spi2-core
47   # https://gitlab.gnome.org/GNOME/at-spi2-core/-/issues/115
48   git revert -n 6c165512fc0d33ba62bff5936b1593480193e764
51 build() {
52   local meson_options=(
53     -D default_bus=dbus-broker
54     -D docs=true
55   )
57   arch-meson at-spi2-core build "${meson_options[@]}"
58   meson compile -C build
61 check() {
62   dbus-run-session meson test -C build --print-errorlogs
65 package_at-spi2-core() {
66   optdepends=('dbus-broker: Alternative bus implementation')
67   provides=(
68     "at-spi2-atk=$pkgver-$pkgrel"
69     "atk=$pkgver-$pkgrel"
70     libatk-1.0.so
71     libatk-bridge-2.0.so
72     libatspi.so
73   )
74   conflicts=(
75     'at-spi2-atk<=2.38.0-2'
76     'atk<=2.38.0-2'
77   )
78   replaces=(
79     'at-spi2-atk<=2.38.0-2'
80     'atk<=2.38.0-2'
81   )
83   meson install -C build --destdir "$pkgdir"
85   mkdir -p doc/usr/share
86   mv {"$pkgdir",doc}/usr/share/doc
89 package_at-spi2-core-docs() {
90   pkgdesc+=" (documentation)"
91   depends=()
93   mv doc/* "$pkgdir"
96 # vim:set sw=2 sts=-1 et: