1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=freecell-solver
6 pkgdesc='A program that automatically solves layouts of Freecell and similar variants of Card Solitaire'
8 url='https://fc-solve.shlomifish.org'
11 makedepends=(cmake gperf perl-moo perl-path-tiny perl-template-toolkit python-random2 python-six python-pysol_cards rinutils)
12 optdepends=('python-random2: for the Python interface' 'python-six: for the Python interface'
13 'python-pysol_cards: for the Python interface')
14 source=(https://fc-solve.shlomifish.org/downloads/fc-solve/$pkgname-$pkgver.tar.xz)
15 sha256sums=('95f78a4b15d2fa340271fe4fcc5354065968191ba22db0d40e81b291b8d53d32')
18 cmake -B build -S $pkgname-$pkgver \
19 -DCMAKE_INSTALL_PREFIX=/usr \
20 -DFCS_WITH_TEST_SUITE=OFF \
21 -DBUILD_STATIC_LIBRARY=OFF
26 DESTDIR="$pkgdir" cmake --install build
27 install -Dm644 $pkgname-$pkgver/COPYING.html "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.html