db-move: moved evolution-ews from [testing] to [extra] (x86_64)
[arch-packages.git] / python-bootstrap / trunk / PKGBUILD
blobd25284f568907fe0473d9c218f1a2252ed3e2b8c
1 # Maintainer
3 pkgbase=python-bootstrap
4 pkgname=(python-build python-installer python-tomli python-pep517 python-setuptools python-flit-core python-wheel)
5 pkgver=0.1
6 pkgrel=1
7 arch=(any)
8 license=('custom')
9 makedepends=(python git)
10 url="https://gitlab.archlinux.org/archlinux/python-bootstrap"
11 # From archlinux-contrib
12 # package/parse-submodules https://github.com/jelly/python-bootstrap.git
13 source=(
14   "${pkgbase}::git+https://github.com/jelly/python-bootstrap.git#branch=3.11"
15   "${pkgbase}-build::git+https://github.com/pypa/build.git"
16   "${pkgbase}-flit::git+https://github.com/takluyver/flit.git"
17   "${pkgbase}-installer::git+https://github.com/pypa/installer.git"
18   "${pkgbase}-pep517::git+https://github.com/pypa/pep517.git"
19   "${pkgbase}-setuptools::git+https://github.com/pypa/setuptools.git"
20   "${pkgbase}-tomli::git+https://github.com/hukkin/tomli.git"
21   "${pkgbase}-wheel::git+https://github.com/pypa/wheel.git"
23 sha256sums=('SKIP'
24             'SKIP'
25             'SKIP'
26             'SKIP'
27             'SKIP'
28             'SKIP'
29             'SKIP'
30             'SKIP')
32 prepare() {
33   cd python-bootstrap
34   git submodule init
36   git config submodule."external/build".url "${srcdir}/${pkgbase}"-build
37   git config submodule."external/flit".url "${srcdir}/${pkgbase}"-flit
38   git config submodule."external/installer".url "${srcdir}/${pkgbase}"-installer
39   git config submodule."external/pep517".url "${srcdir}/${pkgbase}"-pep517
40   git config submodule."external/setuptools".url "${srcdir}/${pkgbase}"-setuptools
41   git config submodule."external/tomli".url "${srcdir}/${pkgbase}"-tomli
42   git config submodule."external/wheel".url "${srcdir}/${pkgbase}"-wheel
44   git -c protocol.file.allow=always submodule update
45   git submodule update --init --recursive
49 build() {
50   cd python-bootstrap
51   python -m bootstrap.build
54 package_python-build() {
55   depends=(python-pep517 python)
56   pkgdesc="A simple, correct PEP 517 build frontend"
57   cd python-bootstrap
58   python -m bootstrap.install dist/build-*-py3-none-any.whl -d $pkgdir
61 package_python-installer() {
62   depends=(python-pep517 python)
63   pkgdesc="Low-level library for installing a Python package from a wheel distribution"
64   cd python-bootstrap
65   python -m bootstrap.install dist/installer-*-py3-none-any.whl -d $pkgdir
68 package_python-flit-core() {
69   depends=(python-pep517 python)
70   pkgdesc="Simplified packaging of Python modules (core backend)"
71   cd python-bootstrap
72   python -m bootstrap.install dist/flit_core-*-py3-none-any.whl -d $pkgdir
75 package_python-pep517() {
76   pkgdesc="Wrappers to build Python packages using PEP 517 hooks"
77   depends=(python)
78   cd python-bootstrap
79   python -m bootstrap.install dist/pep517-*-py3-none-any.whl -d $pkgdir
82 package_python-setuptools() {
83   pkgdesc="Easily download, build, install, upgrade, and uninstall Python packages"
84   depends=(python)
85   cd python-bootstrap
86   python -m bootstrap.install dist/setuptools-*-py3-none-any.whl -d $pkgdir
89 package_python-tomli() {
90   pkgdesc="A lil' TOML parser"
91   depends=(python)
92   cd python-bootstrap
93   python -m bootstrap.install dist/tomli-*-py3-none-any.whl -d $pkgdir
96 package_python-wheel() {
97   pkgdesc="A built-package format for Python"
98   depends=(python)
99   cd python-bootstrap
100   python -m bootstrap.install dist/wheel-*-py2.py3-none-any.whl -d $pkgdir