archrelease: copy trunk to staging-x86_64
[arch-packages.git] / alsa-firmware / trunk / PKGBUILD
blob706ba326f1b48a15b2f965ab306878f3bbc25200
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Tobias Powalowski <tpowa@archlinux.org>
3 # Contributor: Jochen Immendörfer <jochen dot immendoerfer at gmail dot com>
5 # NOTE: mixartloader/miXart8.elf is a blob lacking full RELRO and PIE
6 # https://mailman.alsa-project.org/pipermail/alsa-devel/2020-January/161887.html
8 pkgname=alsa-firmware
9 pkgver=1.2.4
10 pkgrel=3
11 pkgdesc="Firmware binaries for loader programs in alsa-tools and hotplug firmware loader"
12 arch=(any)
13 url="https://alsa-project.org/"
14 license=(BSD GPL2 LGPL2.1 custom)
15 source=(https://www.alsa-project.org/files/pub/firmware/$pkgname-$pkgver.tar.bz2{,.sig})
16 options=(!strip)
17 sha512sums=('041f54744fe30fa94781968c89c77ab9073fc9a828014d07a0f7e0f11c4185ace6846d5d2a313fcca6e9cda6e4837fd6f62e883b0fdb0a4e30a8c18ba7b2e05d'
18             'SKIP')
19 b2sums=('0f844f6cc4859b72635f24d347b4c790469aee39aa60d9addb2c168dcf06b48e7e3cbba26ff21c7e1f5aa355641eec7ab934cb09bfac8ca116a6ac6a7db9d548'
20         'SKIP')
21 validpgpkeys=('F04DF50737AC1A884C4B3D718380596DA6E59C91') # ALSA Release Team (Package Signing Key v1) <release@alsa-project.org>
23 prepare() {
24   cd $pkgname-$pkgver
25   autoreconf -fiv
28 build() {
29   local configure_options=(
30     --prefix=/usr
31     --enable-buildfw
32     --with-hotplug-dir=/usr/lib/firmware
33   )
35   cd $pkgname-$pkgver
36   ./configure "${configure_options[@]}"
37   make
40 package() {
41   cd $pkgname-$pkgver
42   make DESTDIR="$pkgdir" install
43   # remove files which conflict with linux-firmware
44   rm -rf "$pkgdir"/usr/lib/firmware/{ct{efx,speq}.bin,ess,korg,sb16,yamaha}
45   # remove broken symlinks (broken upstream)
46   rm -rf "$pkgdir"/usr/lib/firmware/turtlebeach
47   install -vDm 644 aica/license.txt -t "$pkgdir/usr/share/licenses/$pkgname/aica/"
48   install -vDm 644 ca0132/creative.txt -t "$pkgdir/usr/share/licenses/$pkgname/ca0132/"