archrelease: copy trunk to staging-x86_64
[arch-packages.git] / gtk2-perl / trunk / PKGBUILD
blob2e9d0a7d146e68123c281ef31eaf601df21240e5
1 # Maintainer: Jan de Groot <jgc@archlinux.org>
2 # Contributor: Sarah Hay <sarah@archlinux.org>
4 pkgname=gtk2-perl
5 pkgver=1.24993
6 pkgrel=4
7 pkgdesc="Perl bindings for GTK+ 2.x"
8 arch=(x86_64)
9 license=('LGPL')
10 url="http://gtk2-perl.sourceforge.net/"
11 makedepends=('perl-extutils-pkgconfig' 'perl-extutils-depends')
12 depends=('gtk2' 'pango-perl')
13 checkdepends=('ttf-dejavu' 'xorg-server-xvfb')
14 options=('!emptydirs')
15 source=(https://downloads.sourceforge.net/sourceforge/gtk2-perl/Gtk2-${pkgver}.tar.gz)
16 sha512sums=('320b10803394b196e0833ab998b854c7e184d6f291657c732a1fddb0c049d01ef192c73e6a095a87b18ff8cb9ac846fcb3682a2dd0c9c86076342e3ca7e55eb5')
18 prepare() {
19   cd Gtk2-$pkgver
20   # Disable failing test. Doesn't work for several versions, might be related to Xvfb too
21   #sed -e 's/gnome-foot.png/gnome-foot2.png/' -i t/GdkPixbufLoader.t
24 build() {
25   cd Gtk2-$pkgver
26   export PERL_USE_UNSAFE_INC=1
27   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
28   make
31 #check() {
32 #  cd Gtk2-$pkgver
33 #  xvfb-run -a -s "-extension GLX -screen 0 1280x1024x24" make test
36 package() {
37   cd Gtk2-$pkgver
38   make install DESTDIR="${pkgdir}"