archrelease: copy trunk to staging-x86_64
[arch-packages.git] / kopete / trunk / PKGBUILD
blob3103c076c8a4591123d5722b769957ccad6d4d8d
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kopete
6 pkgver=23.04.0
7 pkgrel=1
8 pkgdesc='Instant Messenger'
9 url='https://apps.kde.org/kopete/'
10 arch=(x86_64)
11 license=(GPL LGPL FDL)
12 groups=(kde-applications kde-network)
13 depends=(knotifyconfig kcmutils ktexteditor kcontacts kidentitymanagement libkleo qca-qt5 kdelibs4support khtml
14          libidn libotr)
15 makedepends=(extra-cmake-modules libgadu jsoncpp kdoctools kdesignerplugin kdnssd kinit)
16 optdepends=('libgadu: Gadu-Gadu protocol' 'kdnssd: bonjour protocol')
17 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
18 sha256sums=('3f5e12f268f4a721c8482e1d2b8a06b944cd57e3decba9284efed47f4cd4c370'
19             'SKIP')
20 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
21               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
22               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
24 build() {
25   cmake -B build -S $pkgname-$pkgver \
26     -DBUILD_TESTING=OFF
27   cmake --build build
30 package() {
31   DESTDIR="$pkgdir" cmake --install build