archrelease: copy trunk to staging-x86_64
[arch-packages.git] / libxcomposite / trunk / PKGBUILD
blobaefd46f23cec3afa6f81b5b5d94437f3579f8e8c
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=libxcomposite
5 pkgver=0.4.6
6 pkgrel=1
7 pkgdesc="X11 Composite extension library"
8 arch=('x86_64')
9 url="https://xorg.freedesktop.org/"
10 license=('custom')
11 depends=('libxfixes')
12 makedepends=('xorg-util-macros' 'xorgproto')
13 source=("${url}/releases/individual/lib/libXcomposite-${pkgver}.tar.xz"{,.sig})
14 sha512sums=('f35a0da8f9f22fd788eee01209557fe3a1b1abdc9744f76330ba42b21b6e3af5464ca4451c33415856417c30da5aa5624e3707980c644327249bfeda5a62a59b'
15             'SKIP')
16 validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # "Alan Coopersmith <alan.coopersmith@oracle.com>"
18 build() {
19   cd libXcomposite-${pkgver}
20   ./configure --prefix=/usr --sysconfdir=/etc --disable-static
21   make
24 package() {
25   cd libXcomposite-${pkgver}
26   make DESTDIR="${pkgdir}" install
28   install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
29   install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"