archrelease: copy trunk to staging-x86_64
[arch-packages.git] / perl-file-listing / trunk / PKGBUILD
blob2c25e24cc0ca5b0967cc4bcd0f3df989b31efa6e
1 # Maintainer:
3 pkgname=perl-file-listing
4 pkgver=6.15
5 pkgrel=2
6 pkgdesc="parse directory listing"
7 arch=('any')
8 url="https://search.cpan.org/dist/File-Listing"
9 license=('PerlArtistic' 'GPL')
10 depends=('perl' 'perl-http-date')
11 options=('!emptydirs')
12 source=("https://search.cpan.org/CPAN/authors/id/P/PL/PLICEASE/File-Listing-${pkgver}.tar.gz")
13 sha512sums=('8368605bf196750f4044d87a8b784e6a28fa6fe6d5971c5de507b4df77859020dcba4929ce97f5091966a6a2fca94466a345450f2f9d2fad9fb88d880f491944')
15 build() {
16   cd File-Listing-${pkgver}
17   perl Makefile.PL INSTALLDIRS=vendor
18   make
21 check() {
22   cd File-Listing-${pkgver}
23   make test
26 package() {
27   cd File-Listing-${pkgver}
28   make DESTDIR="$pkgdir" install