archrelease: copy trunk to staging-x86_64
[arch-packages.git] / python-hyperlink / trunk / PKGBUILD
blob14195470eec1ddf727289d6d50cc48c87c9b0e30
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-hyperlink
4 pkgver=21.0.0
5 pkgrel=5
6 pkgdesc='A featureful, correct URL for Python'
7 arch=('any')
8 license=('BSD')
9 url='https://github.com/python-hyper/hyperlink'
10 depends=('python-idna')
11 makedepends=('python-setuptools')
12 checkdepends=('python-pytest-runner')
13 source=("https://github.com/python-hyper/hyperlink/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
14 sha512sums=('fa6c9da0e414319bf20be66dc5593b3fe2e8772c62d36adf2de32c277e49469ada952ca591f41fae8d2229812d79f1e6b7eaa23e63995c7f02ce10aa5569cd61')
16 build() {
17   cd hyperlink-$pkgver
18   python setup.py build
21 check() {
22   cd hyperlink-$pkgver
23   python setup.py pytest
25   # clean-up non-reproducible files generated during test
26   rm -rf hyperlink/test/__pycache__/
29 package() {
30   cd hyperlink-$pkgver
32   python setup.py install --root="$pkgdir" --optimize=1
33   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
36 # vim:set ts=2 sw=2 et: