archrelease: copy trunk to staging-x86_64
[arch-packages.git] / rrdtool / repos / extra-x86_64 / PKGBUILD
blob85c53d63f998affa2343b2bc98ffc0c4bde3e076
1 # Maintainer: Eric BĂ©langer <eric@archlinux.org>
3 pkgname=rrdtool
4 pkgver=1.8.0
5 pkgrel=2
6 pkgdesc="Data logging and graphing application"
7 arch=('x86_64')
8 url="https://www.rrdtool.org"
9 license=('GPL' 'custom')
10 depends=('libxml2' 'pango' 'ttf-dejavu')
11 makedepends=('intltool' 'ruby' 'python-setuptools' 'tcl' 'lua51' 'systemd')
12 optdepends=('perl: to use corresponding binding'
13             'tcl: to use corresponding binding'
14             'python: to use corresponding binding'
15             'ruby: to use corresponding binding'
16             'lua51: to use corresponding binding')
17 options=('!emptydirs' '!makeflags')
18 source=(https://github.com/oetiker/rrdtool-1.x/releases/download/v$pkgver/rrdtool-$pkgver.tar.gz)
19 sha256sums=('bd37614137d7a8dc523359648eb2a81631a34fd91a82ed5581916a52c08433f4')
21 prepare() {
22   cd ${pkgname}-${pkgver}
24   # fix FS#28521 make ruby install to vendor_ruby instead of site_ruby
25   sed -e 's/$(RUBY) ${abs_srcdir}\/ruby\/extconf.rb/& --vendor/' -i bindings/Makefile.am
27   # https://github.com/oetiker/rrdtool-1.x/issues/1135
28   autoreconf -vi
31 build() {
32   cd ${pkgname}-${pkgver}
33   LUA=/usr/bin/lua5.1 \
34     LUA_CFLAGS="-I/usr/include/lua5.1 -llua5.1" LUA_INSTALL_CMOD="/usr/lib/lua/5.1" \
35     ./configure --prefix=/usr --localstatedir=/var --disable-rpath \
36     --enable-perl --enable-perl-site-install --with-perl-options='INSTALLDIRS=vendor' \
37     --enable-ruby --enable-ruby-site-install --enable-python \
38     --enable-lua --enable-lua-site-install --enable-tcl --disable-libwrap
39   make
42 package() {
43   cd ${pkgname}-${pkgver}
44   make DESTDIR="${pkgdir}" includedir=/usr/include install
45   install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"