archrelease: copy trunk to staging-x86_64
[arch-packages.git] / libgcrypt / trunk / PKGBUILD
blobd1422ca834826d2ba9d0ab919497ea050d831b91
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
3 # after a .so bump first rebuild dirmngr
4 # with sudo testing-x86_64-build -- -I libgcrypt-1.6.0-1-x86_64.pkg.tar.xz
5 # then cp /usr/lib/libgcrypt.so.11 /var/lib/archbuild/staging-x86_64/root/usr/lib/ and do staging-x86_64-build
7 pkgname=libgcrypt
8 pkgver=1.10.2
9 pkgrel=1
10 pkgdesc="General purpose cryptographic library based on the code from GnuPG"
11 arch=(x86_64)
12 url="https://www.gnupg.org"
13 license=('LGPL')
14 depends=('libgpg-error')
15 options=('!emptydirs')
16 # https://www.gnupg.org/download/integrity_check.html
17 source=(https://gnupg.org/ftp/gcrypt/${pkgname}/${pkgname}-${pkgver}.tar.bz2{,.sig})
18 sha256sums=('3b9c02a004b68c256add99701de00b383accccf37177e0d6c58289664cce0c03'
19             'SKIP')
20 validpgpkeys=('6DAA6E64A76D2840571B4902528897B826403ADA') # "Werner Koch (dist signing 2020)"
21 #validpgpkeys=('AC8E115BF73E2D8D47FA9908E98E9B2D19C6C8BD') # Niibe Yutaka (GnuPG Release Key)
23 prepare() {
24   cd "${pkgname}"-${pkgver}
26   # tests fail due to systemd+libseccomp preventing memory syscalls when building in chroots
27   #  t-secmem: line 176: gcry_control (GCRYCTL_INIT_SECMEM, pool_size, 0) failed: General error
28   #  FAIL: t-secmem
29   #  t-sexp: line 1174: gcry_control (GCRYCTL_INIT_SECMEM, 16384, 0) failed: General error
30   #  FAIL: t-sexp
31   sed -i "s:t-secmem::" tests/Makefile.am
32   sed -i "s:t-sexp::" tests/Makefile.am
33   autoreconf -vfi
36 build() {
37   cd "${pkgname}"-${pkgver}
38   ./configure --prefix=/usr \
39         --disable-static \
40         --disable-padlock-support
41   make
44 check() {
45   cd "${pkgname}"-${pkgver}
46   make check
49 package() {
50   cd "${pkgname}"-${pkgver}
51   make DESTDIR="${pkgdir}" install