1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
5 pkgname=(python-gobject)
8 pkgdesc="Python Bindings for GLib/GObject/GIO/GTK+"
9 url="https://wiki.gnome.org/Projects/PyGObject"
13 gobject-introspection-runtime
27 optdepends=('cairo: Cairo bindings')
28 provides=("pygobject-devel=$pkgver")
29 conflicts=(pygobject-devel)
30 replaces=('pygobject-devel<=3.36.1-1')
31 _commit=1a2544c898ca2aafcab0c9e472be22657f310cf3 # tags/3.44.1^0
33 "git+https://gitlab.gnome.org/GNOME/pygobject.git#commit=$_commit"
39 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
47 arch-meson pygobject build
48 meson compile -C build
52 PYTEST_ADDOPTS="-v" PYGI_TEST_VERBOSE=1 \
53 xvfb-run -s '-nolisten local' \
54 meson test -C build --print-errorlogs
57 package_python-gobject() {
58 meson install -C build --destdir "$pkgdir"
59 python -m compileall -d /usr/lib "$pkgdir/usr/lib"
60 python -O -m compileall -d /usr/lib "$pkgdir/usr/lib"
63 # vim:set sw=2 sts=-1 et: