archrelease: copy trunk to extra-x86_64
[arch-packages.git] / baobab / repos / extra-x86_64 / PKGBUILD
blobf8fa479f698219ec2f8f8e35eff98d953c61c242
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=baobab
5 pkgver=42.0
6 pkgrel=1
7 pkgdesc="A graphical directory tree analyzer"
8 url="https://wiki.gnome.org/Apps/DiskUsageAnalyzer"
9 arch=(x86_64)
10 license=(GPL2)
11 depends=(dconf gtk4 gsettings-desktop-schemas librsvg libadwaita)
12 makedepends=(vala gobject-introspection yelp-tools appstream-glib git meson)
13 groups=(gnome)
14 options=(debug)
15 _commit=bffc1c040ee75e0cb0675d0bc1a59619ff57366c  # tags/42.0^0
16 source=("git+https://gitlab.gnome.org/GNOME/baobab.git#commit=$_commit"
17         no-mimetype.diff)
18 sha256sums=('SKIP'
19             '958a85fe3a2001d16ebcf71b51888f260508af87224a0de3410a6bbe685e59d0')
21 pkgver() {
22   cd baobab
23   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
26 prepare() {
27   cd baobab
29   # https://bugs.archlinux.org/task/31861
30   git apply -3 ../no-mimetype.diff
33 build() {
34   arch-meson baobab build
35   meson compile -C build
38 check() {
39   meson test -C build --print-errorlogs
42 package() {
43   meson install -C build --destdir "$pkgdir"