1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
7 pkgdesc="Create and modify archives"
8 url="https://wiki.gnome.org/Apps/FileRoller"
11 depends=(libhandy dconf libarchive file json-glib libnotify zip unzip)
12 makedepends=(yelp-tools git libnautilus-extension meson appstream-glib)
13 optdepends=('p7zip: 7z, arj, exe and encrypted zip files support'
14 'unrar: better RAR archive support'
15 'unace: ACE archive support'
16 'lrzip: lrzip archive support'
17 'squashfs-tools: squashfs image support')
20 _commit=f6f1798376cb9b64ee865d354f1c330ea3e56bcd # tags/3.42.0^0
21 source=("git+https://gitlab.gnome.org/GNOME/file-roller.git#commit=$_commit")
26 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
34 arch-meson $pkgname build
35 meson compile -C build
39 meson test -C build --print-errorlogs
43 meson install -C build --destdir "$pkgdir"