archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gcr / trunk / PKGBUILD
blob67b77ef56ae54bd3740a855cce23f384abb1132a
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgbase=gcr
5 pkgname=(gcr gcr-docs)
6 pkgver=3.41.1
7 pkgrel=1
8 pkgdesc="A library for bits of crypto UI and parsing"
9 url="https://gitlab.gnome.org/GNOME/gcr"
10 arch=(x86_64)
11 license=(GPL2)
12 depends=(gtk3 libgcrypt p11-kit openssh libsecret)
13 makedepends=(gobject-introspection vala libxslt git gi-docgen meson)
14 options=(debug)
15 _commit=664f8d8619cc6d661bd863107824efbac383a9bf  # tags/3.41.1^0
16 source=("git+https://gitlab.gnome.org/GNOME/gcr.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd gcr
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd gcr
28 build() {
29   arch-meson gcr build
30   meson compile -C build
33 check() {
34   # Secure memory tests fail
35   dbus-run-session meson test -C build --print-errorlogs || :
38 package_gcr() {
39   provides=(libgck-1.so libgcr-{base,ui}-3.so)
40   backup=(etc/security/limits.d/10-gcr.conf)
41   install=gcr.install
43   meson install -C build --destdir "$pkgdir"
45   # gcr wants to lock some memory to prevent swapping out private keys
46   # https://bugs.archlinux.org/task/32616
47   # https://bugzilla.gnome.org/show_bug.cgi?id=688161
48   install -Dm644 /dev/stdin "$pkgdir/etc/security/limits.d/10-gcr.conf" <<END
49 @users - memlock 1024
50 END
52   mkdir -p doc/usr/share
53   mv {"$pkgdir",doc}/usr/share/doc
56 package_gcr-docs() {
57   pkgdesc+=" (documentation)"
58   depends=()
60   mv doc/* "$pkgdir"
63 # vim:set sw=2 sts=-1 et: