archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-calendar / trunk / PKGBUILD
blob7032e1b141513286fda9f4f1fc2a92a5bc86662a
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-calendar
5 pkgver=42.2
6 pkgrel=1
7 pkgdesc="Simple and beautiful calendar application designed to perfectly fit the GNOME desktop"
8 url="https://wiki.gnome.org/Apps/Calendar"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(evolution-data-server libsoup libadwaita libgweather-4 geoclue
12          geocode-glib gsettings-desktop-schemas gnome-control-center)
13 makedepends=(git meson)
14 groups=(gnome)
15 options=(debug)
16 _commit=0207e3902efe3dae1dbd96264cd239fb91b8f573  # tags/42.2^0
17 source=("git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd $pkgname
22   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd $pkgname
29 build() {
30   arch-meson $pkgname build
31   meson compile -C build
34 check() {
35   meson test -C build --print-errorlogs
38 package() {
39   meson install -C build --destdir "$pkgdir"
42 # vim:set sw=2 et: