archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnote / trunk / PKGBUILD
blobe987d1210a95b8c15a008072887d1c9e6df886ac
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 # Contributor: uastasi <uastasi@archlinux.us>
6 pkgname=gnote
7 pkgver=42.1
8 pkgrel=1
9 pkgdesc="A note taking application"
10 url="https://wiki.gnome.org/Apps/Gnote"
11 arch=(x86_64)
12 license=(GPL3)
13 depends=(gtkmm3 gspell libxslt libsecret)
14 makedepends=(yelp-tools meson git)
15 options=(debug)
16 _commit=bcad054a73490356c45940360f5c589937dda5e3  # tags/42.1^0
17 source=("git+https://gitlab.gnome.org/GNOME/gnote.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd gnote
22   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd gnote
29 build() {
30   arch-meson gnote build
31   meson compile -C build
34 check() {
35   meson test -C build
38 package() {
39   meson install -C build --destdir "$pkgdir"