archrelease: copy trunk to extra-x86_64
[arch-packages.git] / itinerary / kde-unstable / PKGBUILD
blob031665e89f95f9ee5288eab8963a22e6a0afc3c1
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=itinerary
4 pkgver=22.07.90
5 pkgrel=1
6 pkgdesc='Itinerary and boarding pass management application'
7 arch=(x86_64)
8 url='https://apps.kde.org/itinerary/'
9 license=(LGPL BSD)
10 depends=(kitinerary kio networkmanager-qt kosmindoormap khealthcertificate qt5-location qqc2-desktop-style prison
11          kitemmodels kunitconversion kfilemetadata)
12 makedepends=(extra-cmake-modules)
13 groups=(kde-applications kde-pim)
14 source=(https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
15 sha256sums=('34b9ae148efe3c907e8aa4cd30a5f9b6deb76ae9ff01dc753c93a2975c068265'
16             'SKIP')
17 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
18               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
19               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
20 options=(debug)
22 build() {
23   cmake -B build -S $pkgname-$pkgver \
24     -DBUILD_TESTING=OFF
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build
31   install -Dm644 $pkgname-$pkgver/LICENSES/* -t "$pkgdir"/usr/share/licenses/$pkgname