archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kaccounts-integration / repos / kde-unstable-x86_64 / PKGBUILD
blobb03b110e5de9ec2b25312d9ac290caeae2d6d844
1 # Maintainer: Antonio Rojas <arojas@archlinux.org> 
3 pkgname=kaccounts-integration
4 pkgver=22.07.90
5 pkgrel=1
6 pkgdesc='Small system to administer web accounts for the sites and services across the KDE desktop, including: Google, Facebook, Owncloud, IMAP, 
7 Jabber and others'
8 arch=(x86_64)
9 url='https://www.kde.org/'
10 license=(GPL)
11 depends=(kcmutils signon-kwallet-extension signon-plugin-oauth2 signon-ui)
12 makedepends=(extra-cmake-modules kdoctools)
13 source=(https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
14 sha256sums=('43e44b000d448d5bafd9a0c49afa922768a6eda5fef5c02c4b7002e127a750ea'
15             'SKIP')
16 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
17               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
18               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
19 options=(debug)
21 build() {
22   cmake -B build -S $pkgname-$pkgver \
23     -DBUILD_TESTING=OFF
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build