archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kdepim-runtime / kde-unstable / PKGBUILD
blobe41c3a23732db2b7430a7dd234d9860f15f63d60
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
4 # Contributor: Pierre Schmitz <pierre@archlinux.de>
6 pkgname=kdepim-runtime
7 pkgver=22.07.90
8 pkgrel=1
9 pkgdesc='Extends the functionality of kdepim'
10 arch=(x86_64)
11 url='https://kontact.kde.org'
12 license=(GPL LGPL FDL)
13 depends=(libkolabxml kdav kholidays akonadi-calendar knotifyconfig kmbox pimcommon akonadi-notes akonadi qca-qt5 qt5-networkauth)
14 makedepends=(extra-cmake-modules kdoctools libetebase boost)
15 optdepends=('libetebase: EteSync resource')
16 source=(https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
17 sha256sums=('1c94e553e651371de436e391a6217ba6341f7df801c12bd44940a32d6c8b3625'
18             'SKIP')
19 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
20               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
21               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
22 options=(debug)
24 build() {
25   cmake -B build -S $pkgname-$pkgver \
26     -DBUILD_TESTING=OFF
27   cmake --build build
30 package() {
31   DESTDIR="$pkgdir" cmake --install build