archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libaccounts-glib / trunk / PKGBUILD
blob9f086e4101900ba1a2a64dc33147d8fab473db56
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: Balló György <ballogyor+arch at gmail dot com>
5 pkgname=libaccounts-glib
6 pkgver=1.25
7 pkgrel=7
8 pkgdesc='Glib-based client library for accessing the online accounts database'
9 arch=(x86_64)
10 url='https://gitlab.com/accounts-sso/libaccounts-glib'
11 license=(LGPL)
12 depends=(glib2 libxml2 sqlite)
13 makedepends=(python-gobject gobject-introspection vala meson check)
14 source=(https://gitlab.com/accounts-sso/libaccounts-glib/-/archive/VERSION_$pkgver/libaccounts-glib-VERSION_$pkgver.tar.gz)
15 sha256sums=('47d4b2a5cf4f17f52550aa65b34030fbd1a242e1a233f248a5871620e0ff4c11')
17 build() {
18   meson $pkgname-VERSION_$pkgver build \
19     -Dprefix=/usr
20   meson compile -C build
23 check() {
24   meson test -C build || true
27 package() {
28   meson install -C build --destdir "$pkgdir"